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Aerial Photo Rectification 

ERDAS Imagine 2016  

  
 

Description:   We will be using ERDAS Imagine to georeference aerial photos to a DOQ 
image. We will try to achieve this with a total RMS (root mean square) error of less than 
one half pixel.  
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Rectifying scanned aerial photos of southeast Minnesota using   
ERDAS Imagine  

 
 

Objective:  To rectify 1:15,840 aerial photos with a total RMS (root mean square) error of less 
than 0.5 pixels (0.5 meters).  
 
Background:  The color infrared aerial photos of southeast Minnesota that you will be working 
with were acquired by the Minnesota Department of Natural Resources at a nominal scale of 
1:15,840.  They were scanned at a resolution of 300dpi (dots per inch) to produce a digital image.  
The data are in the Imagine file format (IMG). 
 
General Overview: Rectification is the process of transforming the data from one grid 
system into another grid system using a geometric transformation.  It may involve correction of 
feature displacement in an aerial photograph in order to produce a planimetrically correct image 
of the landscape.  The georeferencing process is accomplished by matching corresponding points 
from an already georeferenced image (in our case Digital Orthophoto Quads (DOQs)) with the 
same points on the scanned aerial photo image.  This series of points will then be used to compute 
the best fit polynomial transformation to align the image to the correct geographic area (don't 
worry, the computer does this for you!). 
     
The first goal is to locate the matching corresponding points, or ground control points (GCPs) of 
permanent objects. The best GCPs are stationary features such as road intersections and 
landmarks. In general, you should not choose control points in areas that may change such as 
shorelines, riverbanks or forested areas.  If you must choose natural features, try to find small 
islands in lakes that appear to be similar in both sources.  Select their center/centroid points 
(usually the highest point) in order to try to account for change in water levels.  Other types of 
points that may be helpful are irregular areas in the shorelines along the lake that look very 
similar, or patches of wetlands with a centroid or unique point.  Individual trees are going to be 
very hard to distinguish due to the pixelation of the images, but if you can find one standing alone 
in both images they could also be good GCPs, if necessary.  
 
The second goal will be finding GCPs near the four corners of the image, and evenly distributed 
throughout the image.  If you cluster control point pairs only in a certain area of the image, then 
your rectification is likely to be much less accurate as you move away from those points.  We will 
find 20 or more GCPs, and correct for those which contribute the most error to the overall root 
mean square (RMS) value.   
 
Finally, we will "resample" the image, which essentially fills in the geometrically correct pixels 
with DN values based on the values in the input image.  The three possible resampling methods 
are nearest neighbor, bilinear interpolation and cubic convolution. We’ll use nearest neighbor 
which assigns each corrected output pixel the value of the nearest input pixel while keeping the 
radiometry intact. 
 

For further reference: Read Campbell sec. 11.6, or Lillesand, Kiefer and Chipman sec. 7-2.  



03.3 

Getting Set Up in ERDAS:  

 Start ERDAS Imagine 2016. 
 
 The data needed for this lab is in the S:\FR3252_5262 class folder and Lab 03. To load the 

color photo, right click on 2D View #1 and select Open Raster Layer. The Select Layer to Add 
dialog box will open. Navigate to the file aerialphoto.img and then click OK. Right click on the 
image and Fit to Frame to see the entire image. Click on the Metadata large “i” in the Home 
ribbon tab to view the image metadata. Note this data source is missing spatial reference 
information, but we will remedy that as we continue with the rectification process.  Let's jump 
right in! 

 

Selecting Ground Control Points  
 Be sure the ERDAS window is expanded to full size using the windows 

controls. If it is not, some menu choices may not appear in the steps 
below, though you can navigate to the place via help. Close any other 
ERDAS windows that may be open. 

 To begin georeferencing, first click on the aerialphoto.img in the 2D 
View #1to select the layer. Click on the Multispectral ribbon tab and click on the Control 
Points button. It is part of the Transform & Orthocorrect group. 

 
 The Set Geometric Model dialog box will 

appear. Make sure Model List is selected and 
scroll down in the Select Geometric Model 
listing until you can click on the Polynomial 
model choice and click OK.  Notice there are 
a lot of choices here, choose two or three of 
them and find out more by selecting the 
model type and clicking on 'Help'.   

 
  

 The Multipoint Geometric Correction window will open up 
with your uncorrected imagery and you should get the 
GCP Tool Reference Setup window in front of it.  If the 
radio button is not already selected, make sure the 
reference points will come from Image Layer (New 
Viewer) and click OK.  You will be asked to browse to your 
reference image.                                                                                                                                                                   

    

 The Reference Image Layer dialog opens up. The software 
is asking for the image we will use to provide our 
geographic reference points. Navigate to the Lab 03 folder 
and select doq.img and click OK (or just double click on 

Tip: click the 'Recent' button to more quickly navigate 

to the folder where your reference DOQ is located 
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doq.img 
 

 The Reference Map Information dialog box opens telling us the reference is UTM Zone 15 
NAD83. Just go ahead and click OK to continue 

 
 The Polynomial Model Properties Box 

appears. Click the up arrow to move the 
Polynomial Order to 2 and then the down 
arrow to return it to 1. This should activate 
the Apply button so you can click Apply. Then 
click Close to continue.  If you didn't already 
read the Polynomial Model help document 
earlier, take a look at it now so you get a 
general sense of what the Polynomial Order 
means/does. 

 
 Your screen should now look like this: 

(Multipoint Geometric Correction) 
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 The Multipoint Geometric Correction (MGC) window is now our master work area for the 

rest of the lab. In the left half you have various views of the uncorrected aerial image that 
we want to rectify. In the right half are views of the black and white DOQ image that 
contains our reference geographic information. As we pick matching points in each photo, 
coordinate information of the points will appear in the table at the bottom of the screen. 
 

 You may find that there are GCP points that appear in the color image on the left and in the 
table below the images, which is an interesting bug in ERDAS that makes it difficult to run a 
lab lesson like this.  You can take a look at these points to see what the general distribution 
should look like, but do not keep them - the main task for this lab is for you to create your 
own points!  Select the rows in the table by dragging your mouse from top to bottom (or 
right click and choose Select All) and then Right click to delete.  

 

 Click on the “Toggle Fully Automatic GCP Editing Mode” icon   in the Multipoint 
Geometric Correction window so it is NOT depressed (look in the help documentation to 
find out what this button does). 
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 You will notice in the aerial image in the upper left pane (the least zoomed in pane) there is 
a square white box. If you position your mouse over it the cursor becomes a 4-headed 
arrow. If you click and drag, notice what you see in the larger pane below. Move the 4-
headed cursor around until an easily identifiable object appears in the lower pane (like a 
farm house). Now move the white box in the lower pane until it is directly over the 
farmhouse and notice that in the upper right pane the farmhouse will appear enlarged. 
Take some time to orient yourself to how the various levels of zoom and pointers work 
together. You can change the overall zoom level by right clicking in the lower pane. As you 
do this you will see how the upper left square box changes size to match the view of the 
lower pane. You can also click on the edges of either of the white squares to change the 
relative scene of the pane it represents.  

 
 Try to find some geographical landmarks in the aerial photo. Now, right click on your DOQ 

and select Fit Image to Window. Find the same landmarks on the DOQ that you found in 
the photo. Use the zoom and pan tools to help you. Take some time to set up your window 
so both the input and reference windows are of similar scale.  There are tools at the top of 
the viewer windows and you can also right click in the viewer and left click on “Zoom” to 
select the level of zoom desired. Here’s a sample of how the two should look: 

 

 
 

If you find that the link boxes are difficult to see, you can change their color by right clicking on 
the box and selecting Link Box Color… 
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 Click the Create GCP  in the GCP tool window.  In the highest zoom pane of the aerial 

image, carefully click on an object. GCP#1 will be created. Now Click Create GCP  again 
and Click on the matching object in the DOQ image pane with the highest zoom. GCP#1 will 
be created in that image as well.  

 

 
 
Another Helpful Hint: ERDAS has been 
known to occasionally crash during this 
lab! You should consider saving your 

points periodically. In the File menu, select Save Input As… to save points in the left side of 
the screen to your student drive and select Save Reference As… to save the points on the 
right side of the screen. 

 
 By now you should have GCP #1 listed in the GCP Tool window.  You should have data for 

the X Input and Y Input (the photo location of the GCP) and X Ref. and Y Ref. (the location 
on the DOQ).  Repeat this process for at least six more GCPs. 

 

 Once you have at least six GCPs, you can click on the summation icon  to solve for your 
model (this is where the Polynomial Model is 
doing it's 'behind the scenes work').  

 
 Now you will see X Residual, Y Residual and 

RMS Error information.  You will also see 
Control Point Error for (X) and (Y) and a (Total) 
about your GCP list.  What do these numbers 
represent? 

 
 Continue finding control points with this method until you have a minimum of 20.  More 

GCPs are better, so try using 30 if you can.   
 

 Also, you can try to use the automatic GCP  and automatic solving buttons .  What do 
these applications do for you? 

 
 Cover the photo thoroughly in selecting your GCPs!  It is important to distribute the 

ground control point pairs over the entire aerial photo, extending all the way to the 
corners.  Try to get a GCP close to each of the four corners.  This may be challenging if you 
are on top of a bluff in a field where there are few roads and other permanent features.  

 
 

 
 

Helpful Hint: If the two Binocular icons are depressed  

any time you click on a row containing the GCPs, the 

main screen will display the corresponding Input and 

Reference point 
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Minimizing the Root Mean Square Error  
 

 The RMSE is important because it is a measure of the spatial error in the photo.  We seek 
the smallest RMSE we can achieve.   
 

 The residual columns give a measure of how much each point contributes to the total 
positional error.  The X and Y residual will help you understand the contribution to the 
error by direction. To achieve the best possible RMSE (less than 0.5 pixels at a minimum - 
you need to know the pixel size of your image to translate your total error, which is 
measured in meters), we require careful 
placement of the GCP points.  In the screen 
shot above for example, you might start by 
examining the row that contributed 13.19 to 
the RMS Error. Make certain that the two 
GCPs are placed on the exactly on the same 
location. Move one of them if necessary. Often 
error can be reduced by deleting control 
points and then recreating them, being a bit 
more precise with their location.  While it is 
tempting, a control points with a high residual should not just be deleted. It may likely be 
telling us there is something “going on” in that part of the image that may require other 
actions such as clipping that portion of the image out and processing it separately.   
 

 Often error can be reduced by deleting control points and then recreating them, being a 
bit more precise with their location.  It is often a good idea to delete and re-create the 
first few of your points.  
 

 Another method is to zoom in tightly to the area you are trying to match.  You can move 
the points at this zoomed level and it may be easier for you to align the points.  

 Once you have achieved the lowest RMS error you can achieve ( 0.5 pixels [(Total) < 
0.5]) is an excellent but difficult to achieve goal) and you have twenty GCPs evenly 
spaced throughout the 
image, you are ready to 
resample the aerial photo 
pixels into geographic space.   

 
 In the Multipoint Geometric 

window, click on the Display 
Resample Image Dialog… 
button 

 
 

 The Resample dialog box will 
appear similar to the screen at right. 

Don’t Fudge the Points! You can reduce 

the overall RMSE by deleting “bad” points 

or artificially moving GCPs to where they 

no longer match optically but lower 

RMSE. You will end up with a low RMSE 

but when you overlay your final image the 

pixels will not align well. The proof of 

THIS pudding is in the alignment! 
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 Be sure to save your file as a JPEG2000 (JP2) file type or it will be too large to upload to 
Moodle 

 
 Keep the default values for Output Cell Size and as well as the Output Corners. Make sure 

the Resampling Method is Nearest Neighbor and save your rectified photo to your 
preferred personal location and give it an appropriate name.  

 
 To see your rectified image, open a new viewer and add your image. Your image is now 

ready for further analysis. Well done!  
 

 Import your saved photo into ArcGIS. Load some imagery using File > Add Data > Add 
Basemap > Imagery 

 
 Perform the following steps 
 

1. Right click on your rectified image in the table of contents and select Properties 
2. Select the Display tab and set the transparency to 50% 
3. Right click anywhere in the menu bar area that is plain gray at the top of the 

screen and make certain the Effects menu is clicked 
4. In the Effects menu bar that opens, select your rectified image from the drop 

down and click the  icon .  Your cursor should change to a triangular arrow 
5. Right click on the layer with your image and Zoom to the Layer 
6. Click and drag the arrow across your screen horizontally or vertically to swipe 

the image over the basemap.  
7. To really examine how well the pixels align you will likely need to be around 

1:700 zoom level 
 
 
 

Autosync Workstation 

As you work with Landsat you may find that two images from different time frames of the same geographic 
area may not align accurately. This can be a result of the automated processing that is done by USGS on the 
level 1 prodect. ERDAS Imagine has a functionality called Autosync which is similar to the georeferencing 
we did in the first part of the lab. In this case, you pick one image to be the reference, and the other the 
input. Points are placed across both images and when the model is run, the input is adjusted to match the 
model created by the points you have placed. 

Assuming both images are georeferenced but slightly off, we can easily resolve this using the Edge 
Matching model of Autosync 

Prior to starting Autosycn, your images should both be in stacks. Begin Autosync. You should see: 
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Click OK 
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Make the above changes using your student drive as the directory and whatever name you want for the 
summary report. Click Resample Settings and verify that the screen is as below: 

 

 

Click  OK to this dialog box as well as the Create New Project dialog. 
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File > Add Images > Input Images … 

Browse to the image you would like to adjust 
Click ok and it will appear in the left half of the workspace 
File > Add Images > Input Images … again  
Browse to the second image you would like to use and click OK 
Screen should look like: 
 

 
 
Run APM Model by clicking on  Process > Run APM Model 
 
Run time about 20 minutes. Sample of dialogs while running: 
 

 
 

 
 
Hundreds of points will automatically be placed for you and the screen will appear as: 
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Clicking  will display a copy of the report indicating overall error 

On the upper menu bar click on  to put the preview screen in the upper panel 

 

Click on to put the preview screen in Swipe mode. Review your image to assure you are satisfied with 

the fit. A Blend and Flicker tool is also available. If you want to adjust GSPs click on the again to toggle 



03.14 

back to the review points mode 
 

Click on  to create resampled output for all input images. The output images will have whatever suffix 
you placed in the Project dialog and be placed in the input folder. Statuses will be displaced: 
 

 
 

 
 
Each image will be resampled 
 

 
 

 
 
The above may take a while since both images will need to be resampled and have new pyramid layers 
created. The output files will now show in the table of contents: 
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After completion the images should exactly overly so image differences can more easily be evaluated. 

 

 

Lesson 03 Outcomes 

 
By completing Lesson 03 you should be able to:  

1. Open ERDAS Imagine and load image files.  

2. Fit images to the viewer and zoom to various levels.  

3. Identify features that can be used as ground control points.  

4. Apply the georeferencing tool to an unrectified image.  

5. Identify which ground control points are contributing the most error and delete them.  

6. Minimize the RMS error.  

7. Be comfortable in maneuvering around the photo using the tools available in ERDAS Imagine. 

 
 


